1SUMMARY = "Openbox configuration tool"
2AUTHOR = "Dana Jansens & Tim Riley & Javeed Shaikh"
3HOMEPAGE = "http://openbox.org/wiki/ObConf:About"
4SECTION = "x11/wm"
5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7DEPENDS = " \
8    openbox \
9    startup-notification \
10    gtk+3 \
11"
12PV = "2.0.4+git${SRCPV}"
13
14SRCREV = "63ec47c5e295ad4f09d1df6d92afb7e10c3fec39"
15SRC_URI = " \
16    git://git.openbox.org/dana/obconf;branch=master \
17"
18
19S = "${WORKDIR}/git"
20
21inherit autotools gettext pkgconfig mime mime-xdg features_check
22# depends on openbox, which is X11-only
23REQUIRED_DISTRO_FEATURES = "x11"
24
25EXTRA_AUTORECONF = ""
26
27FILES:${PN} += "\
28    ${datadir}/mime \
29"
30
31do_install:append () {
32    rm -rf ${D}${datadir}/mimelnk
33}
34