1SUMMARY = "Openbox configuration tool"
2HOMEPAGE = "http://openbox.org/wiki/ObConf:About"
3SECTION = "x11/wm"
4LICENSE = "GPL-2.0-or-later"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6DEPENDS = " \
7    openbox \
8    startup-notification \
9    gtk+3 \
10"
11PV = "2.0.4+git"
12
13SRCREV = "63ec47c5e295ad4f09d1df6d92afb7e10c3fec39"
14SRC_URI = " \
15    git://git.openbox.org/dana/obconf;branch=master \
16    file://0001-Fix-function-protype-visibility.patch \
17"
18
19S = "${WORKDIR}/git"
20
21inherit autotools gettext pkgconfig mime mime-xdg features_check
22# depends on openbox, which is X11-only
23REQUIRED_DISTRO_FEATURES = "x11"
24
25EXTRA_AUTORECONF = ""
26
27FILES:${PN} += "\
28    ${datadir}/mime \
29"
30
31do_install:append () {
32    rm -rf ${D}${datadir}/mimelnk
33}
34