1SUMMARY = "LXDM is the lightweight display manager"
2HOMEPAGE = "http://blog.lxde.org/?p=531"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}%20${PV}/${BPN}-${PV}.tar.xz \
6           file://lxdm.conf \
7           ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'file://lxdm-pam file://lxdm-pam-debug', '', d)} \
8           ${@bb.utils.contains("DISTRO_TYPE", "debug", "", "file://0001-lxdm.conf.in-blacklist-root-for-release-images.patch",d)} \
9           file://0002-let-autotools-create-lxdm.conf.patch \
10           file://0003-check-for-libexecinfo-providing-backtrace-APIs.patch \
11           file://0004-fix-css-under-gtk-3.20.patch \
12           "
13SRC_URI[md5sum] = "061caae432634e6db38bbdc84bc6ffa0"
14SRC_URI[sha256sum] = "4891efee81c72a400cc6703e40aa76f3f3853833d048b72ec805da0f93567f2f"
15
16PE = "1"
17
18DEPENDS = "virtual/libintl intltool-native cairo dbus gdk-pixbuf glib-2.0 gtk+3 virtual/libx11 libxcb pango iso-codes"
19DEPENDS += "${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "consolekit", d)}"
20DEPENDS_append_libc-musl = " libexecinfo"
21
22# combine oe-core way with angstrom DISTRO_TYPE
23DISTRO_TYPE ?= "${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", "debug", "",d)}"
24
25inherit autotools pkgconfig gettext systemd features_check
26# depends on virtual/libx11
27REQUIRED_DISTRO_FEATURES = "x11"
28
29CFLAGS_append = " -fno-builtin-fork -fno-builtin-memset -fno-builtin-strstr "
30LDFLAGS_append_libc-musl = " -lexecinfo"
31
32EXTRA_OECONF += "--enable-gtk3=yes --enable-password=yes --with-x -with-xconn=xcb \
33    ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/ --disable-consolekit', '--without-systemdsystemunitdir', d)} \
34    ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)} \
35"
36
37do_configure_prepend() {
38    cp ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po/
39}
40
41do_compile_append() {
42    # default background configured not available / no password field available / no default screensaver
43    sed -i     -e 's,bg=,# bg=,g' \
44        -e 's,# skip_password=,skip_password=,g' \
45        -e 's,# arg=.*,arg=${bindir}/X -s 0,g' \
46        ${S}/data/lxdm.conf.in
47    # add default configuration
48    oe_runmake -C ${B}/data lxdm.conf
49}
50
51do_install_append() {
52    install -d ${D}${localstatedir}/lib/lxdm
53    install -m 644 ${WORKDIR}/lxdm.conf ${D}${localstatedir}/lib/lxdm
54    if ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'true', 'false', d)}; then
55        # ArchLinux version of pam config has the following advantages:
56        # * simple setup of passwordless login
57        # * in XFCE powerdown/restart enabled in logoff dialog
58        install -m 644 ${WORKDIR}/${@bb.utils.contains("DISTRO_TYPE", "debug", "lxdm-pam-debug", "lxdm-pam",d)} ${D}${sysconfdir}/pam.d/lxdm
59    fi
60}
61
62# make installed languages choosable
63pkg_postinst_${PN} () {
64langs=""
65for lang in `find $D${libdir}/locale -maxdepth 1 | grep _ | sort`; do
66lang=`basename $lang`
67if [ "x$langs" = "x" ]; then
68    langs="$lang"
69else
70   langs="$langs $lang"
71fi
72done
73sed -i "s:last_langs=.*$:last_langs=$langs:g" $D${localstatedir}/lib/lxdm/lxdm.conf
74}
75
76RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam-plugin-loginuid', '', d)} setxkbmap bash librsvg-gtk"
77
78RPROVIDES_${PN} += "${PN}-systemd"
79RREPLACES_${PN} += "${PN}-systemd"
80RCONFLICTS_${PN} += "${PN}-systemd"
81SYSTEMD_SERVICE_${PN} = "lxdm.service"
82