1SUMMARY = "Andri's Main Loop"
2DESCRIPTION = "Andri's Main Loop"
3HOMEPAGE = "https://github.com/any1/aml"
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e6f3cfaa39204b96e14b68b9d50d3e4e"
6
7SRC_URI = "git://github.com/any1/aml;branch=master;protocol=https"
8
9SRCREV = "b83f3576ce4187d9285f06e9066ef43a691464d4"
10
11PV = "0.3.0+git"
12
13S = "${WORKDIR}/git"
14
15PACKAGECONFIG ??= ""
16PACKAGECONFIG[examples] = "-Dexamples=true,-Dexamples=false"
17
18PACKAGE_BEFORE_PN += "${PN}-examples"
19ALLOW_EMPTY:${PN}-examples = "1"
20FILES:${PN}-examples = "${bindir}"
21
22inherit meson pkgconfig
23
24AML_EXAMPLES = "ticker nested-ticker reader"
25
26do_install:append () {
27	if ${@bb.utils.contains('PACKAGECONFIG', 'examples', 'true', 'false', d)}; then
28		install -d ${D}${bindir}
29		for bin in ${AML_EXAMPLES}; do
30			install -m 0755 ${B}/examples/$bin ${D}${bindir}
31		done
32	fi
33}
34
35BBCLASSEXTEND = "native"
36