1SUMMARY = "GTK+2 standard themes"
2HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/gnome-themes-standard/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome"
5
6LICENSE = "LGPL-2.1-only"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
8
9inherit gnomebase gettext gtk-icon-cache upstream-version-is-even features_check
10
11ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
12
13DEPENDS += "intltool-native gtk+"
14
15# PV is 3.28 not 3.28.0, so the gnomebase SRC_URI isn't right.
16SRC_URI = "${GNOME_MIRROR}/${BPN}/${PV}/${BPN}-${PV}.tar.xz;name=archive"
17SRC_URI[archive.md5sum] = "f9f2c6c521948da427f702372e16f826"
18SRC_URI[archive.sha256sum] = "7c4ba0bff001f06d8983cfc105adaac42df1d1267a2591798a780bac557a5819"
19
20EXTRA_OECONF = "--disable-gtk3-engine"
21
22do_install:append() {
23        # Only building Adwaita, remove highcontrast files
24        rm -rf ${D}${prefix}/share/themes/HighContrast \
25               ${D}${prefix}/share/icons
26
27	# The libtool archive file is unneeded with shared libs on modern Linux
28	rm -rf ${D}${libdir}/gtk-2.0/2.10.0/engines/libadwaita.la
29}
30
31# There could be gnome-theme-highcontrast as well but that requires
32# gtk+3 and includes lots of icons (is also broken with B != S).
33PACKAGES += "gnome-theme-adwaita \
34             gnome-theme-adwaita-dark \
35             "
36
37FILES:gnome-theme-adwaita = "${prefix}/share/themes/Adwaita \
38                              ${libdir}/gtk-2.0/2.10.0/engines/libadwaita.so"
39
40FILES:gnome-theme-adwaita-dark = "${prefix}/share/themes/Adwaita-dark"
41RDEPENDS:gnome-theme-adwaita-dark = "gnome-theme-adwaita"
42
43# gnome-themes-standard is empty and doesn't exist
44RDEPENDS:${PN}-dev = ""
45