1SUMMARY = "GTK+2 standard themes"
2HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/gnome-themes-standard/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome"
5
6LICENSE = "LGPL-2.1-only"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
8
9GNOMEBASEBUILDCLASS = "autotools"
10GTKIC_VERSION = '3'
11inherit gnomebase gettext gtk-icon-cache upstream-version-is-even features_check
12
13ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
14
15DEPENDS += "intltool-native gtk+3 librsvg"
16
17# PV is 3.28 not 3.28.0, so the gnomebase SRC_URI isn't right.
18SRC_URI = "${GNOME_MIRROR}/${BPN}/${PV}/${BPN}-${PV}.tar.xz;name=archive"
19SRC_URI[archive.md5sum] = "f9f2c6c521948da427f702372e16f826"
20SRC_URI[archive.sha256sum] = "7c4ba0bff001f06d8983cfc105adaac42df1d1267a2591798a780bac557a5819"
21
22EXTRA_OECONF = "--disable-gtk2-engine"
23
24do_install:append() {
25        # Only building Adwaita, remove highcontrast files
26        rm -rf ${D}${datadir}/themes/HighContrast \
27               ${D}${datadir}/icons
28
29	# The libtool archive file is unneeded with shared libs on modern Linux
30	rm -rf ${D}${libdir}/gtk-2.0/2.10.0/engines/libadwaita.la
31}
32
33# There could be gnome-theme-highcontrast as well but that requires
34# gtk+3 and includes lots of icons (is also broken with B != S).
35PACKAGES += "gnome-theme-adwaita \
36             gnome-theme-adwaita-dark \
37             "
38
39FILES:gnome-theme-adwaita = "${datadir}/themes/Adwaita \
40                              ${libdir}/gtk-2.0/2.10.0/engines/libadwaita.so"
41
42FILES:gnome-theme-adwaita-dark = "${datadir}/themes/Adwaita-dark"
43RDEPENDS:gnome-theme-adwaita-dark = "gnome-theme-adwaita"
44
45# gnome-themes-standard is empty and doesn't exist
46RDEPENDS:${PN}-dev = ""
47