1SUMMARY = "Common macros for building GNOME applications"
2HOMEPAGE = "http://www.gnome.org/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SECTION = "x11/gnome"
9GNOMEBASEBUILDCLASS = "autotools"
10inherit gnomebase allarch
11
12SRC_URI[archive.md5sum] = "933258d9c23e218eb6eec9cc1951b053"
13SRC_URI[archive.sha256sum] = "22569e370ae755e04527b76328befc4c73b62bfd4a572499fde116b8318af8cf"
14
15EXTRA_AUTORECONF = ""
16DEPENDS = ""
17
18# Default to enable autoconf-archive to avoid conflicts
19PACKAGECONFIG ??= "autoconf-archive"
20PACKAGECONFIG[autoconf-archive] = "--with-autoconf-archive, --without-autoconf-archive, autoconf-archive,autoconf-archive"
21
22FILES:${PN} += "${datadir}/aclocal"
23FILES:${PN}-dev = ""
24
25BBCLASSEXTEND = "native"
26