1LICENSE = "LGPL-2.1-only"
2LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
3DESCRIPTION = "Runtime libraries for parsing and creating MIME mail"
4SECTION = "libs"
5
6DEPENDS = "glib-2.0 zlib"
7
8GNOMEBASEBUILDCLASS = "autotools"
9inherit gnomebase gobject-introspection vala gtk-doc
10
11SRC_URI = "https://github.com/jstedfast/${BPN}/releases/download/${PV}/${BP}.tar.xz \
12    file://iconv-detect.h \
13"
14SRC_URI[sha256sum] = "84cd2a481a27970ec39b5c95f72db026722904a2ccf3fdbd57b280cf2d02b5c4"
15
16UPSTREAM_CHECK_URI = "https://github.com/jstedfast/gmime/releases"
17UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)"
18
19EXTRA_OECONF += "--enable-largefile"
20
21export ac_cv_have_iconv_detect_h="yes"
22export ac_cv_sys_file_offset_bits="64"
23
24do_configure:append () {
25    cp ${UNPACKDIR}/iconv-detect.h ${S}
26}
27