1SUMMARY = "A GObject library to create cabinet files"
2HOMEPAGE = "https://gitlab.gnome.org/GNOME/gcab"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6DEPENDS = "glib-2.0"
7
8SRC_URI = "\
9    ${GNOME_MIRROR}/gcab/${PV}/gcab-${PV}.tar.xz \
10    file://run-ptest \
11"
12SRC_URI[sha256sum] = "2f0c9615577c4126909e251f9de0626c3ee7a152376c15b5544df10fc87e560b"
13
14inherit gobject-introspection gtk-doc manpages meson ptest-gnome vala
15
16PACKAGECONFIG ??= "\
17    ${@bb.utils.contains('USE_NLS', 'yes', 'nls', '', d)} \
18    ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
19"
20PACKAGECONFIG[manpages] = ""
21PACKAGECONFIG[nls] = "-Dnls=true,-Dnls=false"
22PACKAGECONFIG[tests] = "-Dtests=true -Dinstalled_tests=true,-Dtests=false -Dinstalled_tests=false"
23
24BBCLASSEXTEND = "native"
25