1SUMMARY = "Terminal multiplexer"
2HOMEPAGE = "http://tmux.sourceforge.net"
3SECTION = "console/utils"
4
5LICENSE = "ISC"
6LIC_FILES_CHKSUM = "file://tmux.c;beginline=3;endline=17;md5=f256b76d52e7b4d02bf19144bdaca107"
7
8DEPENDS = "ncurses libevent bison-native"
9
10SRC_URI = "https://github.com/tmux/tmux/releases/download/${PV}/tmux-${PV}.tar.gz"
11SRC_URI[sha256sum] = "2fe01942e7e7d93f524a22f2c883822c06bc258a4d61dba4b407353d7081950f"
12
13UPSTREAM_CHECK_URI = "https://github.com/tmux/tmux/releases"
14UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)"
15
16inherit autotools pkgconfig
17
18PACKAGECONFIG ??= ""
19PACKAGECONFIG[utempter] = "ac_cv_header_utempter_h=yes,ac_cv_header_utempter_h=no,libutempter,"
20
21do_configure:prepend() {
22    # The 'compat' directory is needed for output during the build but it's
23    # not automatically created when building outside the source directory.
24    mkdir -p ${B}/compat
25}
26