1SUMMARY = "Hardware performance monitoring counters"
2HOMEPAGE = "https://team.inria.fr/pacap/software/tiptop/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5DEPENDS = "ncurses libxml2 bison-native flex-native"
6
7SRC_URI = "http://files.inria.fr/pacap/${BPN}/${BP}.tar.gz \
8           file://0001-Fix-parallel-build-problems-by-Adrian-Bunk.patch \
9           file://0002-fix-reproducibility-of-build-process.patch \
10           file://0001-Fix-build-when-S-B.patch \
11           file://0001-Fix-a-lot-of-Werror-format-security-errors-with-mvwp.patch \
12           "
13SRC_URI[sha256sum] = "51c4449c95bba34f16b429729c2f58431490665d8093efaa8643b2e1d1084182"
14
15UPSTREAM_CHECK_URI = "https://team.inria.fr/pacap/software/tiptop/"
16
17inherit autotools
18
19EXTRA_OECONF = "CFLAGS="$CFLAGS -I${STAGING_INCDIR}/libxml2""
20COMPATIBLE_HOST = "(i.86|x86_64|arm|powerpc|aarch64).*-linux"
21
22do_configure:prepend () {
23    # Two bugs in configure.ac when cross-compiling.
24    # 1. The path of libxml2. Specify it in EXTRA_OECONF.
25    # 2. hw's value on other platforms. Replace it if the target is
26    #    not i*86/x86_64.
27    if ( echo "${TARGET_ARCH}" | grep -q -e 'i.86' -e 'x86_64' ); then
28        sed -i 's= -I/usr/include/libxml2=='    ${S}/configure.ac
29    else
30        sed -i 's/hw=`uname -m`/hw="unknown"/'  ${S}/configure.ac
31        sed -i 's= -I/usr/include/libxml2=='    ${S}/configure.ac
32    fi
33}
34