1*eb8dc403SDave CobbleySUMMARY = "Hardware performance monitoring counters"
2*eb8dc403SDave CobbleyHOMEPAGE = "http://tiptop.gforge.inria.fr/"
3*eb8dc403SDave CobbleyLICENSE = "GPLv2"
4*eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5*eb8dc403SDave CobbleyDEPENDS = "ncurses libxml2"
6*eb8dc403SDave Cobbley
7*eb8dc403SDave CobbleySRC_URI = "http://tiptop.gforge.inria.fr/releases/${BP}.tar.gz"
8*eb8dc403SDave CobbleySRC_URI[md5sum] = "46ca0fdf0236f02dd2b96d347626d2a2"
9*eb8dc403SDave CobbleySRC_URI[sha256sum] = "51c4449c95bba34f16b429729c2f58431490665d8093efaa8643b2e1d1084182"
10*eb8dc403SDave Cobbley
11*eb8dc403SDave Cobbleyinherit autotools-brokensep
12*eb8dc403SDave CobbleyEXTRA_OECONF = "CFLAGS="$CFLAGS -I${STAGING_INCDIR}/libxml2""
13*eb8dc403SDave CobbleyCOMPATIBLE_HOST = "(i.86|x86_64|arm|powerpc).*-linux"
14*eb8dc403SDave Cobbley
15*eb8dc403SDave Cobbleydo_configure_prepend () {
16*eb8dc403SDave Cobbley    # Two bugs in configure.ac when cross-compiling.
17*eb8dc403SDave Cobbley    # 1. The path of libxml2. Specify it in EXTRA_OECONF.
18*eb8dc403SDave Cobbley    # 2. hw's value on other platforms. Replace it if the target is
19*eb8dc403SDave Cobbley    #    not i*86/x86_64.
20*eb8dc403SDave Cobbley    if ( echo "${TARGET_ARCH}" | grep -q -e 'i.86' -e 'x86_64' ); then
21*eb8dc403SDave Cobbley        sed -i 's= -I/usr/include/libxml2=='    ${S}/configure.ac
22*eb8dc403SDave Cobbley    else
23*eb8dc403SDave Cobbley        sed -i 's/hw=`uname -m`/hw="unknown"/'  ${S}/configure.ac
24*eb8dc403SDave Cobbley        sed -i 's= -I/usr/include/libxml2=='    ${S}/configure.ac
25*eb8dc403SDave Cobbley    fi
26*eb8dc403SDave Cobbley}
27