1eb8dc403SDave CobbleySUMMARY = "Hardware performance monitoring counters"
2595f6308SAndrew GeisslerHOMEPAGE = "https://team.inria.fr/pacap/software/tiptop/"
3*9aee5003SAndrew GeisslerLICENSE = "GPL-2.0-only"
4eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
51a4b7ee2SBrad BishopDEPENDS = "ncurses libxml2 bison-native flex-native"
6eb8dc403SDave Cobbley
7595f6308SAndrew GeisslerSRC_URI = "http://files.inria.fr/pacap/${BPN}/${BP}.tar.gz \
81a4b7ee2SBrad Bishop           file://0001-Fix-parallel-build-problems-by-Adrian-Bunk.patch \
91a4b7ee2SBrad Bishop           file://0002-fix-reproducibility-of-build-process.patch \
101a4b7ee2SBrad Bishop           file://0001-Fix-build-when-S-B.patch \
11595f6308SAndrew Geissler           file://0001-Fix-a-lot-of-Werror-format-security-errors-with-mvwp.patch \
121a4b7ee2SBrad Bishop           "
13eb8dc403SDave CobbleySRC_URI[sha256sum] = "51c4449c95bba34f16b429729c2f58431490665d8093efaa8643b2e1d1084182"
14eb8dc403SDave Cobbley
15595f6308SAndrew GeisslerUPSTREAM_CHECK_URI = "https://team.inria.fr/pacap/software/tiptop/"
16595f6308SAndrew Geissler
171a4b7ee2SBrad Bishopinherit autotools
181a4b7ee2SBrad Bishop
19eb8dc403SDave CobbleyEXTRA_OECONF = "CFLAGS="$CFLAGS -I${STAGING_INCDIR}/libxml2""
201a4b7ee2SBrad BishopCOMPATIBLE_HOST = "(i.86|x86_64|arm|powerpc|aarch64).*-linux"
21eb8dc403SDave Cobbley
22213cb269SPatrick Williamsdo_configure:prepend () {
23eb8dc403SDave Cobbley    # Two bugs in configure.ac when cross-compiling.
24eb8dc403SDave Cobbley    # 1. The path of libxml2. Specify it in EXTRA_OECONF.
25eb8dc403SDave Cobbley    # 2. hw's value on other platforms. Replace it if the target is
26eb8dc403SDave Cobbley    #    not i*86/x86_64.
27eb8dc403SDave Cobbley    if ( echo "${TARGET_ARCH}" | grep -q -e 'i.86' -e 'x86_64' ); then
28eb8dc403SDave Cobbley        sed -i 's= -I/usr/include/libxml2=='    ${S}/configure.ac
29eb8dc403SDave Cobbley    else
30eb8dc403SDave Cobbley        sed -i 's/hw=`uname -m`/hw="unknown"/'  ${S}/configure.ac
31eb8dc403SDave Cobbley        sed -i 's= -I/usr/include/libxml2=='    ${S}/configure.ac
32eb8dc403SDave Cobbley    fi
33eb8dc403SDave Cobbley}
34