1eb8dc403SDave CobbleySUMMARY = "Hardware performance monitoring counters"
2eb8dc403SDave CobbleyHOMEPAGE = "http://tiptop.gforge.inria.fr/"
3eb8dc403SDave CobbleyLICENSE = "GPLv2"
4eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5*1a4b7ee2SBrad BishopDEPENDS = "ncurses libxml2 bison-native flex-native"
6eb8dc403SDave Cobbley
7*1a4b7ee2SBrad BishopSRC_URI = "http://tiptop.gforge.inria.fr/releases/${BP}.tar.gz \
8*1a4b7ee2SBrad Bishop           file://0001-Fix-parallel-build-problems-by-Adrian-Bunk.patch \
9*1a4b7ee2SBrad Bishop           file://0002-fix-reproducibility-of-build-process.patch \
10*1a4b7ee2SBrad Bishop           file://0001-Fix-build-when-S-B.patch \
11*1a4b7ee2SBrad Bishop           "
12eb8dc403SDave CobbleySRC_URI[md5sum] = "46ca0fdf0236f02dd2b96d347626d2a2"
13eb8dc403SDave CobbleySRC_URI[sha256sum] = "51c4449c95bba34f16b429729c2f58431490665d8093efaa8643b2e1d1084182"
14eb8dc403SDave Cobbley
15*1a4b7ee2SBrad Bishopinherit autotools
16*1a4b7ee2SBrad Bishop
17eb8dc403SDave CobbleyEXTRA_OECONF = "CFLAGS="$CFLAGS -I${STAGING_INCDIR}/libxml2""
18*1a4b7ee2SBrad BishopCOMPATIBLE_HOST = "(i.86|x86_64|arm|powerpc|aarch64).*-linux"
19eb8dc403SDave Cobbley
20eb8dc403SDave Cobbleydo_configure_prepend () {
21eb8dc403SDave Cobbley    # Two bugs in configure.ac when cross-compiling.
22eb8dc403SDave Cobbley    # 1. The path of libxml2. Specify it in EXTRA_OECONF.
23eb8dc403SDave Cobbley    # 2. hw's value on other platforms. Replace it if the target is
24eb8dc403SDave Cobbley    #    not i*86/x86_64.
25eb8dc403SDave Cobbley    if ( echo "${TARGET_ARCH}" | grep -q -e 'i.86' -e 'x86_64' ); then
26eb8dc403SDave Cobbley        sed -i 's= -I/usr/include/libxml2=='    ${S}/configure.ac
27eb8dc403SDave Cobbley    else
28eb8dc403SDave Cobbley        sed -i 's/hw=`uname -m`/hw="unknown"/'  ${S}/configure.ac
29eb8dc403SDave Cobbley        sed -i 's= -I/usr/include/libxml2=='    ${S}/configure.ac
30eb8dc403SDave Cobbley    fi
31eb8dc403SDave Cobbley}
32