1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3# Released under the BSD-3-Clause license (see COPYING.BSD-3 for the terms)
4#
5SUMMARY = "A compression/decompression library"
6DESCRIPTION = "Snappy is a fast data compression and decompression library \
7It was designed to be very fast and stable, but not to achieve a high \
8compression ratio."
9
10LICENSE = "BSD-3-Clause"
11LIC_FILES_CHKSUM = "file://COPYING;md5=f62f3080324a97b3159a7a7e61812d0c"
12
13SRC_URI = "gitsm://github.com/google/snappy.git;protocol=https;branch=main \
14	   file://fix-build-on-32bit-arm.patch"
15
16SRCREV = "dc05e026488865bc69313a68bcc03ef2e4ea8e83"
17
18S = "${WORKDIR}/git"
19
20inherit cmake pkgconfig
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[lzo] = "-DHAVE_LIBLZO2=1,-DHAVE_LIBLZO2=0,lzo,"
24TARGET_CFLAGS += "-fPIC"
25
26EXTRA_OECMAKE += '-DBUILD_SHARED_LIBS="ON" -DSNAPPY_BUILD_TESTS="OFF" -DSNAPPY_BUILD_BENCHMARKS="OFF"'
27
28CVE_PRODUCT = "google:snappy"
29