1# Copyright (c) 2019 Christophe Chapuis <chris.chapuis@gmail.com>
2# Copyright (c) 2019 Herman van Hazendonk <github.com@herrie.org>
3
4SUMMARY = "A very simple convenience library for handling properties and signals in C++11."
5SECTION = "libs"
6LICENSE = "LGPL-3.0-only"
7LIC_FILES_CHKSUM = "file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
8
9PV = "0.0.1+git${SRCPV}"
10
11SRCREV = "45863e849b39c4921d6553e6d27e267a96ac7d77"
12SRC_URI = "git://github.com/lib-cpp/${BPN}.git;branch=master;protocol=https"
13
14S = "${WORKDIR}/git"
15
16do_configure:prepend() {
17    echo " " > ${S}/tests/CMakeLists.txt
18}
19
20inherit cmake pkgconfig
21
22RDEPENDS:${PN}-dev = ""
23