1SUMMARY = "PAM searchless LDAP authentication module"
2HOMEPAGE = "https://github.com/rmbreak/pam_ldapdb"
3BUGTRACKER = "https://github.com/rmbreak/pam_ldapdb/issues"
4SECTION = "libs"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=41ab94182d94be9bb35e2a8b933f1e7d"
7
8DEPENDS = "libpam openldap"
9
10inherit features_check
11REQUIRED_DISTRO_FEATURES = "pam"
12
13SRCREV = "3e026863cad1fd45c760ee1bc93ef4f0606cc852"
14SRC_URI = "git://github.com/rmbreak/pam_ldapdb;branch=master;protocol=https"
15
16S = "${WORKDIR}/git"
17
18do_install () {
19    oe_runmake install DESTDIR=${D} PAMDIR=${base_libdir}/security
20}
21
22FILES:${PN} += "${base_libdir}/security/pam_ldapdb.so"
23