1SUMMARY = "7-zip is a commandline utility handling 7z archives."
2HOMEPAGE = "http://www.7-zip.org/"
3LICENSE = "LGPL-2.1+ & unRAR"
4LIC_FILES_CHKSUM = "file://DOC/copying.txt;md5=4fbd65380cdd255951079008b364516c \
5                    file://DOC/unRarLicense.txt;md5=9c87ddde469ef94aed153b0951d088de \
6                    file://DOC/License.txt;md5=879598edf1f54dddb6930d7581357f8b"
7
8SRC_URI = "http://downloads.sourceforge.net/p7zip/p7zip/${PV}/p7zip_${PV}_src_all.tar.bz2 \
9           file://do_not_override_compiler_and_do_not_strip.patch \
10           file://CVE-2017-17969.patch \
11           file://0001-Fix-narrowing-errors-Wc-11-narrowing.patch \
12           "
13
14SRC_URI[md5sum] = "a0128d661cfe7cc8c121e73519c54fbf"
15SRC_URI[sha256sum] = "5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6e2341f"
16
17S = "${WORKDIR}/${BPN}_${PV}"
18
19do_install() {
20	install -d ${D}${bindir}
21	install -m 0755 ${S}/bin/* ${D}${bindir}
22	ln -s 7za ${D}${bindir}/7z
23}
24
25BBCLASSEXTEND = "native"
26