1SUMMARY = "Set of CLI tools for Openlmi providers"
2DESCRIPTION = "openlmi-tools is a set of command line tools for Openlmi providers."
3HOMEPAGE = "http://www.openlmi.org/"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://../COPYING;md5=75859989545e37968a99b631ef42722e"
6SECTION = "System/Management"
7
8inherit setuptools
9
10DEPENDS = "python-native python-pywbem-native python-m2crypto python-pywbem"
11
12SRC_URI = "http://fedorahosted.org/released/${BPN}/${BP}.tar.gz \
13          "
14SRC_URI[md5sum] = "e156246cb7b49753db82f4ddf7f03e50"
15SRC_URI[sha256sum] = "292b8f5f2250655a4add8183c529b73358bc980bd4f23cfa484a940953fce9e4"
16
17S = "${WORKDIR}/${BP}/cli"
18
19do_configure_prepend() {
20    sed 's/@@VERSION@@/$(VERSION)/g' setup.py.skel >setup.py
21}
22
23python() {
24    if 'meta-python' not in d.getVar('BBFILE_COLLECTIONS').split():
25        raise bb.parse.SkipRecipe('Requires meta-python to be present.')
26}
27