1SUMMARY = "A library to handle Apple Property List format whereas it's binary or XML"
2HOMEPAGE = "https://github.com/libimobiledevice/libplist"
3LICENSE = "GPL-2.0-only & LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=ebb5c50ab7cab4baeffba14977030c07 \
5                    file://COPYING.LESSER;md5=6ab17b41640564434dda85c06b7124f7"
6
7DEPENDS = "libxml2 glib-2.0 swig python3"
8
9inherit autotools pkgconfig python3native python3targetconfig
10
11PV = "2.3.0+git"
12
13SRCREV = "2cd858c679d25633077ca78b67182a9b77653816"
14SRC_URI = "git://github.com/libimobiledevice/libplist;protocol=https;branch=master"
15
16S = "${WORKDIR}/git"
17
18CVE_STATUS_GROUPS += "CVE_STATUS_LIBLIST"
19CVE_STATUS_LIBLIST[status] = "fixed-version: The CPE in the NVD database doesn't reflect correctly the vulnerable versions."
20CVE_STATUS_LIBLIST = " \
21    CVE-2017-5834 \
22    CVE-2017-5835 \
23    CVE-2017-5836 \
24"
25
26do_configure:prepend() {
27    rm -f ${S}/m4/ax_python_devel.m4
28}
29
30do_install:append () {
31    if [ -e ${D}${libdir}/python*/site-packages/plist/_plist.so ]; then
32        chrpath -d ${D}${libdir}/python*/site-packages/plist/_plist.so
33    fi
34}
35
36PACKAGES =+ "${PN}-utils \
37             ${PN}++ \
38             ${PN}-python"
39
40FILES:${PN} = "${libdir}/libplist-2.0${SOLIBS}"
41FILES:${PN}++ = "${libdir}/libplist++-2.0${SOLIBS}"
42FILES:${PN}-utils = "${bindir}/*"
43FILES:${PN}-python = "${libdir}/python*/site-packages/*"
44