1SUMMARY = "A library to handle Apple Property List format whereas it's binary or XML"
2HOMEPAGE = "https://github.com/libimobiledevice/libplist"
3LICENSE = "GPL-2.0-only & LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=ebb5c50ab7cab4baeffba14977030c07 \
5                    file://COPYING.LESSER;md5=6ab17b41640564434dda85c06b7124f7"
6
7DEPENDS = "libxml2 glib-2.0 swig python3"
8
9inherit autotools pkgconfig python3native python3targetconfig
10
11SRCREV = "b8fcc89b74c9128a13b07cc15a0ce25dca0cd97e"
12SRC_URI = "git://github.com/libimobiledevice/libplist;protocol=https;branch=master"
13
14S = "${WORKDIR}/git"
15PR = "r1"
16
17CVE_STATUS_GROUPS += "CVE_STATUS_LIBLIST"
18CVE_STATUS_LIBLIST[status] = "fixed-version: The CPE in the NVD database doesn't reflect correctly the vulnerable versions."
19CVE_STATUS_LIBLIST = " \
20    CVE-2017-5834 \
21    CVE-2017-5835 \
22    CVE-2017-5836 \
23"
24
25do_configure:prepend() {
26    rm -f ${S}/m4/ax_python_devel.m4
27}
28
29do_install:append () {
30    if [ -e ${D}${libdir}/python*/site-packages/plist/_plist.so ]; then
31        chrpath -d ${D}${libdir}/python*/site-packages/plist/_plist.so
32    fi
33}
34
35PACKAGES =+ "${PN}-utils \
36             ${PN}++ \
37             ${PN}-python"
38
39FILES:${PN} = "${libdir}/libplist-2.0${SOLIBS}"
40FILES:${PN}++ = "${libdir}/libplist++-2.0${SOLIBS}"
41FILES:${PN}-utils = "${bindir}/*"
42FILES:${PN}-python = "${libdir}/python*/site-packages/*"
43