1DESCRIPTION = "libblockdev is a C library supporting GObject introspection for manipulation of \
2block devices. It has a plugin-based architecture where each technology (like \
3LVM, Btrfs, MD RAID, Swap,...) is implemented in a separate plugin, possibly \
4with multiple implementations (e.g. using LVM CLI or the new LVM DBus API)."
5HOMEPAGE = "http://rhinstaller.github.io/libblockdev/"
6LICENSE = "LGPL-2.0-or-later"
7SECTION = "devel/lib"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
10
11inherit autotools gobject-introspection pkgconfig lib_package
12
13DEPENDS = "autoconf-archive-native glib-2.0 kmod udev libnvme"
14
15SRC_URI = "git://github.com/storaged-project/libblockdev;branch=3.1.x-devel;protocol=https \
16           file://0001-fix-pythondir-for-multilib-when-cross-compiling.patch \
17           "
18SRCREV = "68aaff5556afe26be749c29a2b7cbd714dce3050"
19S = "${WORKDIR}/git"
20
21FILES:${PN} += "${libdir}/python3.*/site-packages"
22
23PACKAGECONFIG ??= "python3 lvm lvm-dbus dm parted fs escrow btrfs crypto mdraid mpath nvdimm tools"
24PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
25PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools, lvm2"
26PACKAGECONFIG[lvm-dbus] = "--with-lvm_dbus, --without-lvm_dbus, multipath-tools, lvm2"
27PACKAGECONFIG[dm] = "--with-dm, --without-dm, multipath-tools, lvm2"
28PACKAGECONFIG[parted] = "--with-part, --without-part, parted"
29PACKAGECONFIG[fs] = "--with-fs, --without-fs, util-linux"
30PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
31PACKAGECONFIG[nvdimm] = "--with-nvdimm, --without-nvdimm, ndctl util-linux"
32PACKAGECONFIG[escrow] = "--with-escrow, --without-escrow, nss volume-key"
33PACKAGECONFIG[btrfs] = "--with-btrfs,--without-btrfs,libbytesize btrfs-tools"
34PACKAGECONFIG[crypto] = "--with-crypto,--without-crypto,cryptsetup nss volume-key"
35PACKAGECONFIG[mdraid] = "--with-mdraid,--without-mdraid,libbytesize"
36PACKAGECONFIG[mpath] = "--with-mpath,--without-mpath, multipath-tools, lvm2"
37PACKAGECONFIG[tools] = "--with-tools,--without-tools,libbytesize libdevmapper"
38
39export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs"
40