1SUMMARY = "Highway is a C++ library for SIMD (Single Instruction, Multiple Data)"
2HOMEPAGE = "https://github.com/google/highway/"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2b42edef8fa55315f34f2370b4715ca9"
6
7inherit cmake
8
9SRC_URI = "git://github.com/google/highway.git;protocol=https;branch=master"
10
11SRCREV = "58b52a717469e62b2d9b8eaa2f5dddb44d4a4cbf"
12S = "${WORKDIR}/git"
13
14EXTRA_OECMAKE = "-DBUILD_TESTING=0 -DCMAKE_BUILD_TYPE=Release"
15CXXFLAGS:append:arm = " -mfp16-format=ieee"
16# Option not supported with clang and its default format for __fp16 anyway with clang
17CXXFLAGS:remove:toolchain-clang = "-mfp16-format=ieee"
18