1SUMMARY = "Lossless compression library and tool"
2DESCRIPTION = "Brotli is a generic-purpose lossless compression algorithm \
3that it is similar in speed to deflate but offers more dense compression."
4HOMEPAGE = "https://github.com/google/brotli"
5BUGTRACKER = "https://github.com/google/brotli/issues"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=941ee9cd1609382f946352712a319b4b"
8
9SRC_URI = "git://github.com/google/brotli.git;branch=master;protocol=https"
10SRCREV= "ed738e842d2fbdf2d6459e39267a633c4a9b2f5d"
11
12S = "${WORKDIR}/git"
13
14inherit cmake lib_package
15
16do_install:append () {
17	for lib in $(ls ${D}${libdir}/*-static.a); do
18		basename=$(basename ${lib})
19		mv -v "${lib}" "${D}${libdir}/$(echo ${basename} | sed s/-static//)"
20	done
21}
22
23BBCLASSEXTEND = "native"
24