1SUMMARY = "Bitwise terminal calculator"
2DESCRIPTION = "Bitwise is multi base interactive calculator \
3supporting dynamic base conversion and bit manipulation.\
4It's a handy tool for low level hackers, \
5kernel developers and device drivers developers."
6
7HOMEPAGE = "https://github.com/mellowcandle/bitwise"
8SECTION = "console/utils"
9
10LICENSE = "GPL-3.0-only"
11LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
12
13SRC_URI = "https://github.com/mellowcandle/bitwise/releases/download/v${PV}/bitwise-v${PV}.tar.gz \
14           file://0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch \
15           file://run-ptest \
16           file://ptest.out.expected \
17           "
18SRC_URI[sha256sum] = "806271fa5bf31de0600315e8720004a8f529954480e991ca84a9868dc1cae97e"
19
20UPSTREAM_CHECK_URI = "https://github.com/mellowcandle/bitwise/releases"
21
22S = "${WORKDIR}/${BPN}-v${PV}"
23
24DEPENDS = "ncurses readline"
25
26inherit autotools ptest
27
28do_install_ptest() {
29    install -d ${D}${PTEST_PATH}
30    install -m 0644 ${WORKDIR}/ptest.out.expected ${D}${PTEST_PATH}/ptest.out.expected
31}
32
33