1SUMMARY = "beep allows you to have the PC speaker issue beeps and beep patterns"
2DESCRIPTION = "beep allows you to have the PC speaker issue beeps and beep \
3patterns with given frequencies, durations, and spacing."
4HOMEPAGE = "https://github.com/spkr-beep/beep"
5BUGTRACKER = "https://github.com/spkr-beep/beep/issues"
6
7LICENSE = "GPL-2.0-or-later"
8LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
9
10SRC_URI = "git://github.com/spkr-beep/beep.git;protocol=https;branch=master \
11           file://0001-beep-library-Make-it-compatible-with-c99.patch"
12SRCREV = "11453a79f2cea81832329b06ca3a284aa7a0a52e"
13S = "${WORKDIR}/git"
14
15EXTRA_OEMAKE = "prefix='${prefix}' CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}'"
16
17do_install() {
18    oe_runmake install DESTDIR='${D}'
19}
20