1SUMMARY = "x86 (SSE) assembler supporting NASM and GAS-syntaxes"
2LICENSE = "MIT"
3HOMEPAGE = "http://www.tortall.net/projects/yasm/"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=a12d8903508fb6bfd49d8d82c6170dd9"
6
7DEPENDS += "flex-native bison-native xmlto-native"
8
9PV = "1.3.0+git${SRCPV}"
10# v1.3.0
11SRCREV = "ba463d3c26c0ece2e797b8d6381b161633b5971a"
12SRC_URI = "git://github.com/yasm/yasm.git;branch=master;protocol=https \
13           file://0001-Do-not-use-AC_HEADER_STDC.patch \
14"
15
16S = "${WORKDIR}/git"
17
18inherit autotools gettext python3native
19
20CACHED_CONFIGUREVARS = "CCLD_FOR_BUILD='${CC_FOR_BUILD}'"
21
22BBCLASSEXTEND = "native"
23
24PARALLEL_MAKE = ""
25