1SUMMARY = "x86 (SSE) assembler supporting NASM and GAS-syntaxes"
2LICENSE = "MIT"
3HOMEPAGE = "http://www.tortall.net/projects/yasm/"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=a12d8903508fb6bfd49d8d82c6170dd9"
6
7DEPENDS += "flex-native bison-native"
8PACKAGECONFIG[docs] = ",,xmlto-native,"
9
10PV = "1.3.0+git${SRCPV}"
11# v1.3.0
12SRCREV = "ba463d3c26c0ece2e797b8d6381b161633b5971a"
13SRC_URI = "git://github.com/yasm/yasm.git;branch=master;protocol=https \
14           file://0001-Do-not-use-AC_HEADER_STDC.patch \
15           file://CVE-2023-31975.patch \
16           file://CVE-2023-37732.patch \
17"
18
19S = "${WORKDIR}/git"
20
21inherit autotools gettext python3native
22
23CACHED_CONFIGUREVARS = "CCLD_FOR_BUILD='${CC_FOR_BUILD}'"
24
25BBCLASSEXTEND = "native"
26
27PARALLEL_MAKE = ""
28
29do_configure:prepend() {
30     # Don't include $CC (which includes path to sysroot) in generated header.
31     sed -i -e "s/^echo \"\/\* generated \$ac_cv_stdint_message \*\/\" >>\$ac_stdint$"// ${S}/m4/ax_create_stdint_h.m4
32}
33