1SUMMARY="SSD1306 OLED I2C drive"
2DESCRIPTION = "SSD1306 OLED I2C driver working in Linux"
3HOMEPAGE = "https://github.com/armlabs/ssd1306_linux"
4SECTION = "console/utils"
5LICENSE = "MIT"
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=7b694e603a996c3bfdc6093ed1f70c8f"
8
9SRC_URI = " \
10    git://github.com/armlabs/ssd1306_linux.git;protocol=https;branch=master \
11"
12SRCREV = "34b42992a43fda69c6ba2557b718601cafe16251"
13
14S = "${WORKDIR}/git"
15
16# coreutils provides fmt which is used in the Makefile
17DEPENDS = "i2c-tools coreutils-native"
18
19EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}'"
20
21do_install() {
22    install -d ${D}${bindir}
23    install -m 0755 ${B}/ssd1306_bin ${D}${bindir}
24}
25