1SUMMARY = "Application to verify operation of serial ports"
2HOMEPAGE = "https://github.com/nsekhar/serialcheck"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6SRC_URI = " \
7    git://github.com/nsekhar/serialcheck.git \
8"
9
10SRCREV = "45eb2ffa5378396e85432872833890b0a1cba872"
11
12S = "${WORKDIR}/git"
13
14inherit autotools
15
16DEPENDS_append_libc-musl = " argp-standalone"
17EXTRA_OEMAKE_append_libc-musl = " LIBS='-largp'"
18
19PACKAGE_BEFORE_PN += "${PN}-stats"
20
21do_install() {
22    install -d ${D}${bindir}
23    install ${B}/serialcheck ${D}${bindir}
24    install ${B}/serialstats ${D}${bindir}
25    install -d ${D}${docdir}/${BP}
26    install ${S}/README ${D}${docdir}/${BP}
27}
28
29FILES_${PN}-stats = "${bindir}/serialstats"
30
31BBCLASSEXTEND = "nativesdk"
32