1SUMMARY = "The Perl Database Interface"
2DESCRIPTION = "DBI is a database access Application Programming Interface \
3(API) for the Perl Language. The DBI API Specification defines a set \
4of functions, variables and conventions that provide a consistent \
5database interface independent of the actual database being used. \
6"
7HOMEPAGE = "http://search.cpan.org/dist/DBI/"
8SECTION = "libs"
9LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=10982c7148e0a012c0fd80534522f5c5"
11
12SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-${PV}.tar.gz \
13           file://CVE-2014-10402.patch \
14           "
15SRC_URI[md5sum] = "352f80b1e23769c116082a90905d7398"
16SRC_URI[sha256sum] = "8a2b993db560a2c373c174ee976a51027dd780ec766ae17620c20393d2e836fa"
17
18S = "${WORKDIR}/DBI-${PV}"
19
20inherit cpan ptest-perl
21
22do_install:prepend() {
23	# test requires "-T" (taint) command line option
24	rm -rf ${B}/t/pod-coverage.t
25	rm -rf ${B}/t/13taint.t
26	# source of test failure not obvious
27	rm -rf ${B}/t/85gofer.t
28	# unclear why there are several duplicates of tests in tarball
29	rm -rf ${B}/t/z*.t
30}
31
32do_install:append() {
33	sed -i "s:^#!.*:#!/usr/bin/env perl:" ${D}${bindir}/dbiproxy \
34		${D}${bindir}/dbiprof ${D}${bindir}/dbilogstrip
35}
36
37RDEPENDS:${PN}:class-target = " \
38    perl \
39    perl-module-carp \
40    perl-module-exporter \
41    perl-module-exporter-heavy \
42    perl-module-dynaloader \
43    perl-module-io-dir \
44    perl-module-scalar-util \
45    perl-module-universal \
46"
47
48RDEPENDS:${PN}-ptest = " \
49    ${PN} \
50    perl-module-b \
51    perl-module-benchmark \
52    perl-module-cwd \
53    perl-module-data-dumper \
54    perl-module-encode \
55    perl-module-encode-byte \
56    perl-module-encode-encoding \
57    perl-module-file-copy \
58    perl-module-file-path \
59    perl-module-lib \
60    perl-module-perlio \
61    perl-module-perlio-scalar \
62    perl-module-perlio-via \
63    perl-module-sdbm-file \
64    perl-module-storable \
65    perl-module-test-more \
66    perl-module-utf8 \
67    "
68
69BBCLASSEXTEND = "native"
70