1SUMMARY = "High-level language, primarily intended for numerical computations"
2HOMEPAGE = "http://www.gnu.org/software/octave/"
3SECTION = "math"
4
5LICENSE = "GPL-3.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
7
8# To build, add 'FORTRAN:forcevariable = ",fortran"' to your local.conf (or use
9# meta-mortsgna as distro :)
10
11DEPENDS = " \
12    gperf-native \
13    libglu \
14    lapack \
15    fftw \
16    curl \
17    freetype \
18    fontconfig \
19    texinfo \
20    pcre \
21    readline \
22    fltk \
23    hdf5 \
24    libsndfile1 \
25"
26
27inherit autotools pkgconfig texinfo gettext gtk-icon-cache mime-xdg features_check
28
29REQUIRED_DISTRO_FEATURES = "x11 opengl"
30
31SRC_URI = " \
32    ${GNU_MIRROR}/octave/${BPN}-${PV}.tar.gz \
33    file://fix-blas-library-integer-size.patch \
34"
35SRC_URI[sha256sum] = "b12cb652587d31c5c382b39ed73463c22a5259ecb2fa6b323a27da409222dacc"
36
37# Note: Qt5Help is required for gui -> qttools(-native) must be build with
38# clang in PACKAGECONFIG
39PACKAGECONFIG[gui] = "--with-qt=yes,--with-qt=no,qttools-native qttools qtbase"
40
41EXTRA_OECONF = " \
42    --disable-java \
43    --disable-docs \
44"
45
46do_compile:prepend() {
47	for folder in "liboctave/operators liboctave/numeric liboctave/array liboctave/util"; do
48		mkdir -p ${B}/${folder}
49	done
50}
51
52FILES:${PN} += "${datadir}/metainfo"
53FILES:${PN}-dev += "${libdir}/${BPN}/${PV}/lib*${SOLIBSDEV}"
54
55# fortran is not enabled by default
56EXCLUDE_FROM_WORLD = "1"
57