1SUMMARY = "MessagePack implementation for C and C++"
2DESCRIPTION = "MessagePack is an efficient binary serialization format. It's like JSON. but fast and small"
3HOMEPAGE = "http://msgpack.org/index.html"
4LICENSE = "BSL-1.0"
5LIC_FILES_CHKSUM = "file://NOTICE;md5=7a858c074723608e08614061dc044352 \
6                    file://COPYING;md5=0639c4209b6f2abf1437c813b208f2d3 \
7                    file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c \
8                   "
9
10SRC_URI = "https://github.com/msgpack/msgpack-c/releases/download/cpp-${PV}/msgpack-cxx-${PV}.tar.gz"
11SRC_URI[sha256sum] = "5fd555742e37bbd58d166199e669f01f743c7b3c6177191dd7b31fb0c37fa191"
12
13UPSTREAM_CHECK_URI = "https://github.com/msgpack/msgpack-c/releases"
14UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)"
15
16S = "${WORKDIR}/msgpack-cxx-${PV}"
17
18DEPENDS += "boost"
19
20inherit cmake pkgconfig
21
22RDEPENDS:${PN}-dev = ""
23
24BBCLASSEXTEND += "native nativesdk"
25