1SUMMARY = "MessagePack implementation for C and C++"
2DESCRIPTION = "MessagePack is an efficient binary serialization format. It's like JSON. but fast and small"
3HOMEPAGE = "http://msgpack.org/index.html"
4LICENSE = "BSL-1.0"
5LIC_FILES_CHKSUM = "file://NOTICE;md5=7a858c074723608e08614061dc044352 \
6                    file://COPYING;md5=0639c4209b6f2abf1437c813b208f2d3 \
7                    file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c \
8                   "
9
10SRC_URI = "git://github.com/msgpack/msgpack-c;branch=c_master;protocol=https \
11           "
12SRCREV = "8160ede5e20fd3019a77eea46d9c72cf6163f802"
13
14S = "${WORKDIR}/git"
15
16inherit cmake pkgconfig
17
18EXTRA_OECMAKE += "-DMSGPACK_BUILD_TESTS=off"
19
20BBCLASSEXTEND += "native nativesdk"
21