1SUMMARY = "Display virtual memory allocation"
2DESCRIPTION = "Lists all the processes, executables, and shared libraries \
3that are using up virtual memory. It's helpful to see how the shared memory \
4is used and which 'old' libs are loaded. \
5"
6HOMEPAGE = "http://memstattool.sourceforge.net/"
7SECTION = "devtool"
8
9LICENSE = "GPL-2.0-only"
10
11S = "${WORKDIR}/memstattool"
12
13LIC_FILES_CHKSUM = "file://debian/copyright;md5=87be186443b1ac2cfa466f475e1ee0cb"
14
15SRC_URI = "http://sourceforge.net/projects/memstattool/files/memstat_${PV}.tar.gz \
16           file://0001-Include-limits.h-for-PATH_MAX-definition.patch \
17           "
18
19SRC_URI[md5sum] = "2c3acc0c62b2a18f6601b84e54aa7462"
20SRC_URI[sha256sum] = "245d5fc7fb87bcfd14486cd34917cae2856e799559ac568434af12c4852bce94"
21
22do_install:append(){
23    install -d ${D}${bindir}
24    install -m 0755 memstat ${D}${bindir}
25    install -d ${D}${sysconfdir}
26    install -m 0755 memstat.conf ${D}${sysconfdir}
27    install -d ${D}${mandir}/man1
28    install -m 0644 memstat.1 ${D}${mandir}/man1
29    install -d ${D}${docdir}/${BPN}
30    install -m 0644 memstat-tutorial.txt ${D}${docdir}/${BPN}
31}
32