1SUMMARY = "Command line utility to communicate with ModBus slave (RTU or TCP)"
2DESCRIPTION = "mbpoll can: read discrete inputs; read and write binary outputs \
3(coil); read input registers; read and write output registers (holding register). \
4The reading and writing registers may be in decimal, hexadecimal or floating single \
5precision."
6LICENSE = "GPL-3.0-only"
7HOMEPAGE = "https://github.com/epsilonrt/mbpoll"
8LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
9DEPENDS = "libmodbus (>=3.1.4)"
10
11SRC_URI = "git://github.com/epsilonrt/mbpoll;protocol=https;branch=master"
12SRCREV = "a0bd6c08d3d15b086f2104477295c0705aed366a"
13
14S = "${WORKDIR}/git"
15
16inherit pkgconfig cmake
17