1SUMMARY = "A self-extracting archiving tool for Unix systems, in 100% shell script."
2DESCRIPTION = "\
3    makeself.sh is a small shell script that generates a self-extractable \
4    compressed tar archive from a directory. The resulting file appears as \
5    a shell script (many of those have a .run suffix), and can be launched as is.\
6"
7HOMEPAGE = "https://makeself.io/"
8LICENSE = "GPL-2.0-only"
9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10
11SRC_URI = "\
12    git://github.com/megastep/${BPN}.git;protocol=https;branch=master \
13"
14
15SRCREV = "09488c50c6bdc40aec8e3a9b23a539c5054a634c"
16
17S = "${WORKDIR}/git"
18
19do_configure[noexec] = "1"
20do_compile[noexec] = "1"
21
22do_install() {
23    install -d ${D}${bindir}
24    install -m 0755 ${S}/makeself.sh ${D}${bindir}/
25    install -m 0755 ${S}/makeself-header.sh ${D}${bindir}/
26}
27
28BBCLASSEXTEND = "native"
29