1SUMMARY = "A C++ JSON Parser/Generator Implemented with Boost Spirit."
2DESCRIPTION = "JSON Spirit, a C++ library that reads and writes JSON files or streams. \
3It is written using the Boost Spirit parser generator. If you are \
4already using Boost, you can use JSON Spirit without any additional \
5dependencies."
6HOMEPAGE = "https://www.codeproject.com/kb/recipes/json_spirit.aspx"
7SECTION = "libs"
8PRIORITY = "optional"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=278ef6183dec4aae1524fccc4b0113c9"
11
12DEPENDS = "boost"
13
14SRC_URI = "file://json_spirit_v${PV}.zip \
15           file://0001-Adjust-the-cmake-files.patch \
16           file://0001-Link-to-libatomic.patch \
17"
18
19S = "${WORKDIR}/json_spirit_v${PV}"
20
21inherit cmake
22
23BBCLASSEXTEND = "nativesdk"
24