14b7c1154SAndrew GeisslerSUMMARY = "Heap memory profiler for Linux"
24b7c1154SAndrew GeisslerDESCRIPTION = "Heaptrack traces all memory allocations and annotates these \
34b7c1154SAndrew Geisslerevents with stack traces. Dedicated analysis tools then allow you to interpret \
44b7c1154SAndrew Geisslerthe heap memory profile to find hotspots to reduce memory, leaks, allocation \
54b7c1154SAndrew Geisslerhotspots and temporary allocations"
64b7c1154SAndrew GeisslerHOMEPAGE = "https://phabricator.kde.org/source/heaptrack/"
79aee5003SAndrew GeisslerLICENSE = "LGPL-2.1-only"
84b7c1154SAndrew GeisslerLIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
94b7c1154SAndrew Geissler
104b7c1154SAndrew GeisslerDEPENDS = "zlib boost libunwind elfutils"
114b7c1154SAndrew Geissler
12595f6308SAndrew GeisslerSRC_URI = "git://github.com/KDE/heaptrack.git;protocol=https;branch=master \
134b7c1154SAndrew Geissler           file://0001-libheaptrack-Replace-__pid_t-with-pid_t.patch \
144b7c1154SAndrew Geissler           file://0002-heaptrack_inject-Include-dlfcn.h-for-dlopen-dlclose.patch \
154b7c1154SAndrew Geissler           file://0003-heaptrack_preload-Make-noexcept-attribute-conditiona.patch \
164b7c1154SAndrew Geissler           file://0004-backtrace-Always-include-stdint.h.patch \
17b95905d1SWilliam A. Kennington III           file://0001-track-Check-for-unw_set_caching_policy-before-using.patch \
184b7c1154SAndrew Geissler           "
194b7c1154SAndrew Geissler
204b7c1154SAndrew GeisslerSRCREV = "bc9e3744bcc47de978673d1e382f4125a1ab5fa8"
214b7c1154SAndrew Geissler
224b7c1154SAndrew GeisslerS = "${WORKDIR}/git"
234b7c1154SAndrew Geissler
244b7c1154SAndrew Geisslerinherit cmake
254b7c1154SAndrew Geissler
264b7c1154SAndrew GeisslerEXTRA_OECMAKE += "-DHEAPTRACK_BUILD_GUI=OFF"
274b7c1154SAndrew Geissler
284b7c1154SAndrew Geissler# libunwind is not yet ported to RISCV
29213cb269SPatrick WilliamsCOMPATIBLE_HOST:riscv32 = "null"
30213cb269SPatrick WilliamsCOMPATIBLE_HOST:riscv64 = "null"
314b7c1154SAndrew Geissler
32*ac13d5f3SPatrick WilliamsBBCLASSEXTEND = "native"
33