1DESCRIPTION = "Concurrency Kit provides a plethora of concurrency primitives, \
2safe memory reclamation mechanisms and non-blocking data structures \
3designed to aid in the design and implementation of high performance \
4concurrent systems."
5
6LICENSE = "BSD-2-Clause & Apache-2.0"
7HOMEPAGE = "http://concurrencykit.org"
8SECTION = "base"
9
10PV = "0.7.0+git"
11SRCREV = "6e8e5bec2e2f8cef2072a68579cbb07ababf3331"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=a0b24c1a8f9ad516a297d055b0294231"
13SRC_URI = "git://github.com/concurrencykit/ck.git;branch=master;protocol=https \
14           file://0001-configure-Fix-compoiler-detection-logic-for-cross-co.patch \
15           file://0001-build-Use-ilp32d-abi-on-riscv32-and-lp64d-on-rv64.patch"
16
17S = "${WORKDIR}/git"
18
19COMPATIBLE_HOST = "(arm|aarch64|i.86|x86_64|powerpc|powerpc64|riscv32|riscv64).*-linux*"
20
21inherit autotools-brokensep
22
23PLAT:powerpc64 = "ppc64"
24PLAT:powerpc64le = "ppc64"
25PLAT:riscv32 = "riscv"
26PLAT ?= "${HOST_ARCH}"
27
28do_configure () {
29    export PLATFORM=${PLAT}
30    ${S}/configure \
31    --prefix=${prefix} \
32    --includedir=${includedir} \
33    --libdir=${libdir}
34}
35
36do_compile () {
37    oe_runmake
38}
39
40do_install () {
41    oe_runmake 'DESTDIR=${D}' install
42}
43