1SUMMARY = "A GNU tool that produce shell scripts to automatically configure software"
2DESCRIPTION = "Autoconf is an extensible package of M4 macros that produce shell scripts to automatically \
3configure software source code packages. Autoconf creates a configuration script for a package from a template \
4file that lists the operating system features that the package can use, in the form of M4 macro calls."
5SECTION = "devel"
6
7HOMEPAGE = "http://www.gnu.org/software/autoconf/"
8
9LICENSE = "GPL-3.0-only"
10LICENSE = "GPL-2.0-only & GPL-3.0-only"
11LIC_FILES_CHKSUM = "file://COPYING;md5=361b6b837cad26c6900a926b62aada5f"
12
13SRC_URI = " \
14    ${GNU_MIRROR}/autoconf/autoconf-${PV}.tar.gz \
15    file://0001-Add-config.guess-config.sub-install-to-destdir.patch \
16"
17
18S = "${WORKDIR}/${BPN}"
19SRC_URI[md5sum] = "9de56d4a161a723228220b0f425dc711"
20SRC_URI[sha256sum] = "f0611136bee505811e9ca11ca7ac188ef5323a8e2ef19cffd3edb3cf08fd791e"
21
22inherit texinfo native
23
24DEPENDS += "m4-native gnu-config-native"
25RDEPENDS:${PN} = "m4-native gnu-config-native"
26
27PERL = "${USRBINPATH}/perl"
28
29CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'"
30
31CONFIGUREOPTS = " \
32    --build=${BUILD_SYS} \
33    --host=${HOST_SYS} \
34    --target=${TARGET_SYS} \
35    --prefix=${prefix} \
36    --exec_prefix=${exec_prefix} \
37    --bindir=${bindir} \
38    --sbindir=${sbindir} \
39    --libexecdir=${libexecdir} \
40    --datadir=${datadir} \
41    --sysconfdir=${sysconfdir} \
42    --sharedstatedir=${sharedstatedir} \
43    --localstatedir=${localstatedir} \
44    --libdir=${libdir} \
45    --includedir=${includedir} \
46    --oldincludedir=${oldincludedir} \
47    --infodir=${infodir} \
48    --mandir=${mandir} \
49    --disable-silent-rules \
50"
51
52EXTRA_OECONF += "ac_cv_path_M4=m4 ac_cv_prog_TEST_EMACS=no"
53
54do_configure() {
55    ./configure ${CONFIGUREOPTS}
56}
57
58do_install() {
59	oe_runmake 'DESTDIR=${D}' install
60
61    # avoid conflicts with standard autotools
62    ver="213"
63    for file in `find ${D}${bindir} -type f`; do
64        mv $file $file$ver
65    done
66	mv ${D}${datadir}/autoconf ${D}${datadir}/autoconf213
67}
68