1SUMMARY = "A library for using PKCS"
2DESCRIPTION = "pkcs11-helper is a library that simplifies the interaction with PKCS \
3providers for end-user applications using a simple API and optional OpenSSL \
4engine. The library allows using multiple PKCS enumerating available token \
5certificates, or selecting a certificate directly by serialized id, handling \
6card removal and card insert events, handling card ie-insert to a different \
7slot, supporting session expiration and much more all using a simple API."
8
9HOMEPAGE = "https://github.com/OpenSC/pkcs11-helper"
10SECTION = "Development/Libraries"
11
12LICENSE = "GPL-2.0-only & BSD-3-Clause"
13LIC_FILES_CHKSUM = " \
14    file://COPYING;md5=30f10d22cfb1ba98ccd714a41ad3311a \
15    file://COPYING.GPL;md5=8a71d0475d08eee76d8b6d0c6dbec543 \
16    file://COPYING.BSD;md5=66b7a37c3c10483c1fd86007726104d7 \
17"
18SRC_URI = "git://github.com/OpenSC/${BPN}.git;branch=master;protocol=https"
19
20S = "${WORKDIR}/git"
21# master
22SRCREV = "8bed16034f629a0361fa8ff89deed2b43dc45d8b"
23PV .= "+1.30.0+git"
24
25UPSTREAM_CHECK_GITTAGREGEX = "pkcs11-helper-(?P<pver>\d+(\.\d+)+)"
26
27DEPENDS = "zlib nettle gnutls gmp openssl nss nspr"
28
29inherit autotools pkgconfig
30
31EXTRA_OECONF = "--disable-static"
32