1SUMMARY = "LibTomCrypt is a public domain open source cryptographic toolkit"
2HOMEPAGE = "https://www.libtom.net/LibTomCrypt"
3SECTION = "libs"
4LICENSE = "Unlicense"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=71baacc459522324ef3e2b9e052e8180"
6
7DEPENDS += "libtool-cross"
8
9SRC_URI = "git://github.com/libtom/libtomcrypt.git;protocol=https;branch=master"
10
11SRCREV = "7e7eb695d581782f04b24dc444cbfde86af59853"
12
13S = "${WORKDIR}/git"
14
15do_compile() {
16    oe_runmake -f makefile.shared
17}
18
19do_install() {
20    oe_runmake -f makefile.shared 'PREFIX=${prefix}' 'DESTDIR=${D}' install
21}
22