1eb8dc403SDave Cobbley# This recipe is intended as a 'simpler' replacement for packagegroup-base.
2eb8dc403SDave Cobbley# Please communicate your use cases and suggestions to the mailinglist(s)
3eb8dc403SDave Cobbley
4eb8dc403SDave CobbleySUMMARY = "Basic task to get a device online"
5eb8dc403SDave Cobbley
6eb8dc403SDave Cobbley
7eb8dc403SDave CobbleyPACKAGE_ARCH = "${MACHINE_ARCH}"
8eb8dc403SDave Cobbleyinherit packagegroup
9eb8dc403SDave Cobbley
10eb8dc403SDave Cobbley# Poke extra recomendations into the list using your machine.conf
11eb8dc403SDave Cobbley#
12eb8dc403SDave CobbleyMACHINE_EXTRA_RRECOMMENDS ?= ""
13eb8dc403SDave Cobbley
14eb8dc403SDave Cobbley#
15eb8dc403SDave Cobbley# Select between dropbear and openssh
16eb8dc403SDave Cobbley# Set TASK_BASIC_SSHDAEMON = "openssh-sshd openssh-sftp openssh-sftp-server" in your DISTRO config to get openssh(d)
17eb8dc403SDave Cobbley#
18eb8dc403SDave CobbleyTASK_BASIC_SSHDAEMON ?= "dropbear openssh-sftp openssh-sftp-server"
19eb8dc403SDave Cobbley
20eb8dc403SDave Cobbley#
21eb8dc403SDave Cobbley# The section below is designed to match with packagegroup-boot, but doesn't depend on it to allow for more freedom
22eb8dc403SDave Cobbley# when writing image recipes.
23eb8dc403SDave Cobbley# It also avoids the choice between connman/networkmanager/ifupdown since that is an image feature, not a
24eb8dc403SDave Cobbley# distro feature.
25eb8dc403SDave Cobbley#
26eb8dc403SDave Cobbley# Util-linux (u)mount is included because the busybox one can't handle /etc/mtab being symlinked to /proc/mounts
27eb8dc403SDave Cobbley#
28*213cb269SPatrick WilliamsRDEPENDS:${PN} = "\
29eb8dc403SDave Cobbley    ${TASK_BASIC_SSHDAEMON} \
30eb8dc403SDave Cobbley    avahi-daemon avahi-utils \
31eb8dc403SDave Cobbley"
32eb8dc403SDave Cobbley
33eb8dc403SDave Cobbley#
34eb8dc403SDave Cobbley# The following section is split in 3:
35eb8dc403SDave Cobbley#   1) Machine features: kernel modules and userspace helpers for those
36eb8dc403SDave Cobbley#   2) Distro features: packages associated with those
37eb8dc403SDave Cobbley#   3) Nice to have: packages that are nice to have, but aren't strictly needed
38eb8dc403SDave Cobbley#
39*213cb269SPatrick WilliamsRRECOMMENDS:${PN} = "\
40eb8dc403SDave Cobbley    ${MACHINE_EXTRA_RRECOMMENDS} \
41eb8dc403SDave Cobbley    ${@bb.utils.contains("MACHINE_FEATURES", "usbhost", "usbutils", "", d)} \
42eb8dc403SDave Cobbley    ${@bb.utils.contains("MACHINE_FEATURES", "alsa", "alsa-utils-alsamixer", "", d)} \
43eb8dc403SDave Cobbley    ${@bb.utils.contains("MACHINE_FEATURES", "usbgadget", "kernel-module-g-ether kernel-module-g-serial kernel-module-g-mass-storage", "", d)} \
44eb8dc403SDave Cobbley    \
4526bdd445SBrad Bishop    ${@bb.utils.contains("DISTRO_FEATURES", "bluetooth", "bluez5", "", d)} \
46eb8dc403SDave Cobbley    ${@bb.utils.contains("DISTRO_FEATURES", "wifi", "iw wpa-supplicant", "", d)} \
47eb8dc403SDave Cobbley    \
48eb8dc403SDave Cobbley    tzdata \
49eb8dc403SDave Cobbley    \
50eb8dc403SDave Cobbley    cpufrequtils \
51eb8dc403SDave Cobbley    htop \
52eb8dc403SDave Cobbley"
53