1SUMMARY  = "OpenCL API Headers"
2DESCRIPTION = "OpenCL compute API headers from Khronos Group"
3LICENSE  = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5SECTION = "base"
6
7S = "${WORKDIR}/git"
8SRCREV = "2368105c0531069fe927989505de7d125ec58c55"
9SRC_URI = "git://github.com/KhronosGroup/OpenCL-Headers.git;branch=main;protocol=https"
10
11do_configure[noexec] = "1"
12do_compile[noexec] = "1"
13ALLOW_EMPTY:${PN} = "1"
14
15do_install () {
16	install -d ${D}${includedir}/CL/
17	install -m 0644 ${S}/CL/*.h ${D}${includedir}/CL
18}
19BBCLASSEXTEND = "native nativesdk"
20