1SUMMARY = "DBus-C++ Library"
2DESCRIPTION = "DBus-c++ attempts to provide a C++ API for D-BUS. The library has a glib and an Ecore mainloop integration. It also offers an optional own main loop."
3HOMEPAGE = "http://dbus-cplusplus.sourceforge.net"
4SECTION = "base"
5LICENSE = "LGPL-2.1-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
7DEPENDS = "dbus expat glib-2.0 libpcre"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/project/dbus-cplusplus/dbus-c++/${PV}/${BP}.tar.gz \
10           file://fix-missing-unistd.h-include.patch \
11           file://remove-CXX_FOR_BUILD-stuff.patch \
12           file://0001-src-eventloop.cpp-use-portable-method-for-initializi.patch \
13           file://0002-tools-generate_proxy.cpp-avoid-possibly-undefined-ui.patch \
14           file://0003-Fixed-undefined-ssize_t-for-clang-3.8.0-on-FreeBSD.patch \
15           file://0004-use-POSIX-poll.h-instead-of-sys-poll.h.patch \
16           file://0001-pipe.c-Use-a-string-instead-of-char.patch \
17           "
18SRC_URI[md5sum] = "e752116f523fa88ef041e63d3dee4de2"
19SRC_URI[sha256sum] = "bc11ac297b3cb010be904c72789695543ee3fdf3d75cdc8225fd371385af4e61"
20
21inherit autotools pkgconfig
22
23EXTRA_OECONF = "--disable-ecore --disable-examples --disable-tests"
24LDFLAGS += "-pthread"
25
26PACKAGE_BEFORE_PN = "${PN}-tools"
27
28FILES:${PN}-tools = "${bindir}"
29
30BBCLASSEXTEND = "native"
31