1SUMMARY = "dbus forwarding daemon"
2LICENSE = "LGPL-2.1-or-later"
3LIC_FILES_CHKSUM = "file://dbus-daemon-proxy.c;endline=19;md5=41df6d21fe1c97d6a1cc22a5bf374cba"
4DEPENDS = "dbus dbus-glib"
5SRCREV = "1226a0a1374628ff191f6d8a56000be5e53e7608"
6PV = "0.0.0+git"
7PR = "r1.59"
8
9SRC_URI = "git://github.com/alban/dbus-daemon-proxy;branch=master;protocol=https \
10           file://0001-dbus-daemon-proxy-Return-DBUS_HANDLER_RESULT_NOT_YET.patch \
11           "
12S = "${WORKDIR}/git"
13
14inherit pkgconfig
15
16do_compile() {
17    ${CC} ${CFLAGS} -o dbus-daemon-proxy dbus-daemon-proxy.c `pkg-config --cflags --libs dbus-glib-1` ${LDFLAGS}
18}
19
20do_install() {
21    install -d ${D}${bindir}
22    install -m 0755 dbus-daemon-proxy ${D}${bindir}
23}
24