1SUMMARY = "Torrent client"
2HOMEPAGE = "http://libtorrent.rakshasa.no/"
3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5
6DEPENDS = "libsigc++-2.0 curl cppunit libtorrent ncurses"
7
8SRC_URI = "git://github.com/rakshasa/rtorrent \
9    file://don-t-run-code-while-configuring-package.patch \
10"
11# v0.9.8
12SRCREV = "6154d1698756e0c4842b1c13a0e56db93f1aa947"
13
14PV = "0.9.8"
15
16S = "${WORKDIR}/git"
17
18PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
19
20PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
21
22inherit autotools pkgconfig
23
24do_configure:prepend() {
25    (cd ${S}; ./autogen.sh; cd -)
26}
27