1SUMMARY = "Torrent client"
2HOMEPAGE = "http://libtorrent.rakshasa.no/"
3LICENSE = "GPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5
6DEPENDS = "autoconf-archive libsigc++-2.0 curl cppunit libtool libtorrent ncurses"
7
8SRC_URI = "git://github.com/rakshasa/rtorrent;branch=master;protocol=https"
9SRCREV = "d067bd802e44f0e6a747aabcc311ada2175fd550"
10
11PV = "0.9.8+git"
12
13S = "${WORKDIR}/git"
14
15PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
16
17PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
18
19inherit autotools pkgconfig
20
21EXTRA_AUTORECONF += "--exclude=aclocal"
22
23CXXFLAGS += "-std=gnu++14"
24