1SUMMARY = "Radio enable/disable command line utility"
2HOMEPAGE = "http://linuxwireless.org/en/users/Documentation/rfkill"
3SECTION = "base"
4LICENSE = "0BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c6036d0eb7edbfced28c4160e5d3fa94"
6
7SRC_URI = "http://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.xz \
8           file://0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch \
9           file://dont.call.git.rev-parse.on.parent.dir.patch"
10
11SRC_URI[sha256sum] = "dffc631c611520478b8a286f57c67a35e8cb5802d376c6ca13b057365432389c"
12
13do_compile() {
14    oe_runmake
15}
16
17do_install() {
18    oe_runmake DESTDIR=${D} install
19}
20
21inherit update-alternatives
22
23ALTERNATIVE:${PN} = "rfkill"
24ALTERNATIVE_PRIORITY = "60"
25ALTERNATIVE_LINK_NAME[rfkill] = "${sbindir}/rfkill"
26